Search results

  1. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Short update - I swapped the ultrabright LED I had installed originally for another clear one with much closer spec to Aion's recommendation and the pedal works perfectly. For anyone reading this far into the thread - mind your LED specs when not buying a full Aion kit! I was an idiot to pick a...
  2. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    I needed to take a break from this one and built the Ring Stinger which was another intimidating Aion board that was waiting it's turn. Turned out perfect, no issues whatsover :) Freakish yet very musical pedal. I plan to come back to the flanger once I get correct clear LED for BBD board -...
  3. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    I sourced everything myself
  4. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    We'll get to the bottom of it. I am 100% all wiring is done per the build docs and there are no shorts so it must be something else that is messing with the mix. I need to check how does the time out jack switch off modulations from space out when you use both in stereo - it seems the switching...
  5. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    I think I just hit a breakthrough - I decided to box the pedal back and spend more time testing it in various settings seeing all components are good - through Time out and Space out separately. First thing I noticed - when I crank Manual all the way I managed to get some modulated settings...
  6. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    It's just a bunch of random issues we've caused. Regarding what you said abt LED1 & 2 - LED1 should stay on, LED2 turns on and starts pulsing as soon as you engage Space switch. LED3 turns on when you hit Time switch but should not pulse. LED4 on the sub board will stay on irrespective of main...
  7. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Make yourself at home, I guess this project might make a community of people traumatized by the Lovetone Flanger build
  8. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Double check on the Ring Lift switch when playing around with it, see below note on this in the build docs: Ring Lift (toggle switch) disconnects the ring (middle) terminal of the Time jack, which is equivalent to the “C” solution in the user manual under the “Time Out” heading without...
  9. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Thanks man, I really appreciate your advice and support on this - I am no good in this part of troubleshooting, never had the chance to go this far :) I was inserting signal from the input end rather than jumping the output path hoping I can skip the part it gets to the BBD board - and somehow...
  10. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Good luck man, I really hope it's something simple in your case - a lot of troubleshooting advice in here for you to go through
  11. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    As a quick update - and kind of a journal for myself - checked all resistor values around, everything is good. I desoldered and double checked all transistors with a component tester, all checked out to be fine as well.
  12. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    I can't bias it unfortunately - not in a normal way at least with signal coming through main input jack. No matter the trimpot positions there is no modulation appearing. I checked chip positions, transistor orientation, diodes etc - only thing I haven't checked yet are the resistor values...
  13. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    I checked that many, many times hoping I switched them around :) they are in right places - unfortunately :) I'll do the probing once I get little more time with it and see if I can find anything obvious
  14. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    No worries I don't plan to go full dissasembly mode XD I was placing them with enough care that I am 99.9999% sure I have all the right values in correct places including polarity / orientation etc. I never played much with audio probing but I guess it's time to wrap a cap on a jack and start...
  15. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Read it back to back multiple times now, same for Aion build docs - I still take steps back and try to think abt anything I could have done wrong here so just checked all my resistor bags to measure and check whether I don't have something mislabeled - I am not measuring each component before...
  16. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    What I am starting to fear is that the JFet specs make a difference here, or at least some of them do and you can't throw random J113's in and wish for the best. I once built a harmonic trem based on a Catalinbread that didn't work until I started swapping J201s with other JFet transistors - if...
  17. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Hearing back from @Synchrony Pedalworks it seems all the LEDs (internal and external ones) are working fine - he's got a working build and checked that
  18. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Glad to know the LED3 is working as it should. At the same time it seems the issue is elsewhere - and reflowing everything on the board including sub board and 3PDT boards did not help. In my example voltages seem more or less in the ballpark - I think they are affected by some settings like...
  19. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Ok thanks and I very much appreciate your willingness to help here :) We're all struggling to understand the magic juices that run pedals ;)
  20. K

    SOLVED Aion Xenotron / Lovetone Flange no BBD modulation

    Im not skilled enough in reading the schematic to tell what drives the voltage sweep that makes the LED pulse, perhaps it's something different entirely and this one should not pulse at all? I don't see the VD circuit being referenced for LED3 in the schematic and I might be bad in reading these...
Back
Top