• International Mail Service Disruptions
    A large number of international shipments have been disrupted by the COVID-19 pandemic. International shipments may experience longer than normal delivery times.
    Read more…

Pythagoras V2 to V3 conversions? (Radium Springs)

TheToneGeek

New member
Hello! I finally got around to building the Pythagoras V2 Radium Springs and I have the same hiss and weird (low) mix volume past 2 o'clock issues as other members mentioned. Does anyone have the original Pythagoras v2 documentation and/or what changed between the circuit board I have and the V3 to improve the hiss and mix? Or did anything change between the silkscreen and the documentation?

I populated the v2 board by using the silkscreen values as a guide so I suspect that the silkscreen does not match up to updated schematics. I compared the v2 schematic to v3 and couldn't tell any difference so I'm thinking it's changed values between the silkscreen and the documentation. The only thing I printed out was the schematic and not the rest of the v2 documentation :-(

Thank you in advance. -Ryan
 

TheToneGeek

New member
Thank you for the quick reply. I printed out the V2 documentation at the time of purchase of the board (Feb 19, 2019). The board looks different from your current Radium Springs 3D pic layout and does not match 100% the v3 documentation on page 1. It looks like there are 6 resistors on the top right corner (R7/R8/R5/R16/R3/R18) in the v3 documentation vs the 5 that is on my physical board? Is it possible to tell if the silkscreen was altered between boards selling on Feb 19th, 2019 and now? I'm going to give my build a solid look over too meanwhile for human error, but it's odd I am having the same behavior as others where the full wet mix is very low volume and the high level of signal to hiss ratio which is why I think something on the silkscreen (now covered with components) might have been a different value than intended. Thank you in advance for your insight.

IMG_20200320_092234.jpg
 
Last edited:

TheToneGeek

New member
Here is the board I received/used. Note: The orange drop is .0022uF per the doc/silkscreen, I just ran out of the nice MLCCs.

Screen Shot 2020-03-21 at 9.29.13 AM.jpg
 
Last edited:

TheToneGeek

New member
Ok. I think I found a difference between v2 and v3. The v3 has a 100k impedance resistor (R20 on v3 schematic) and my v2 does not have that. I'll solder that direct to my output jack and see if that helps anything.

UPDATE: I did add the 100k at the jack itself with no audible difference to my ears.

quick unlisted YouTube video of the pedal with the wet hiss and mix volume drop.
 
Last edited:
Top