NOTE -- New Daisy Seeds have hardware changes that require recompiling libraries

zgrav

Well-known member
I ordered a couple of Daisy Seeds after they were restocked, but the would not work when I tried to install either the reverb or rhythmic delay programs from users on this forum. I contacted the company and was pointed to this thread describing some changes that were made. This is not only a FYI, but also a request to ask if those programs can be updated to work with the new daisy seeds (apparently the updated libraries can work on the old and new versions).
 
I will take a look at that thread and try to update the rhythmic delay. I don't have a new version of the Seed to check if it works, but I may try to grab one or two.

There have also been changes the the daisy library since I posted the code for the rhythmic delay, so even though the compiled file will work on the older generation of Seeds - compiling from source with the up to date daisy library will throw errors.

I also have a harmonic tremolo I have had 95% done for a year and need to post that soon too.
 

tcpoint

Well-known member
Ha. I need to change a couple things in my code so that it works with the daisy updates. I'll try and get some binaries updated soon.
 

tcpoint

Well-known member
Recompiled the files and added a three more binaries. Created a binaries directory. Need to solder on the pins to the new Daisies to test the binaries. Here's the URL if somebody is brave (dumb) enough to give it a whirl. Terranium binaries. [Note: it might take me a day or two - got a couple of analog pedals on workbench - been cranking them out the last 3-4 weeks (20+)]. This is just me messing around. I didn't release some of the source because I'm not sure what shape it's in. If anybody has any suggestions, I might be up to making some changes or adding the source code and letting you. I'm pretty good at porting the DaisyExamples code (when they make sense). If there's a project you want ported over, I can either do it or help you.
 

zgrav

Well-known member
Recompiled the files and added a three more binaries. Created a binaries directory. Need to solder on the pins to the new Daisies to test the binaries. Here's the URL if somebody is brave (dumb) enough to give it a whirl. Terranium binaries. [Note: it might take me a day or two - got a couple of analog pedals on workbench - been cranking them out the last 3-4 weeks (20+)]. This is just me messing around. I didn't release some of the source because I'm not sure what shape it's in. If anybody has any suggestions, I might be up to making some changes or adding the source code and letting you. I'm pretty good at porting the DaisyExamples code (when they make sense). If there's a project you want ported over, I can either do it or help you.
thanks for taking the time. I will check out the new binaries in the next day or two.
 
I recompiled the rhythmic delay v2 code (with very minor changes) and put the bin here. I compiled it using the new DaisySP library, so I think it should work with the new Seed hardware. I don't have a Seed with the new hardware so I cannot test it, but the .bin works on the original Seed hardware. If anyone has a new Seed and wants to test it out and report back that would be great.

Once someone tests it I will upload the new source code.
 
Last edited:
  • Like
Reactions: fig

zgrav

Well-known member
Sorry for the delay responding. I tried the updated rhythmic delay in my terrarium and it does not pass any sound through in bypass or engaged. No errors when the firmware loads, and the LEDs are working. I have another terrarium pedal and I plan to move the daisy into it to see if it works there and let you know. Thanks for working on this!
 
  • Like
Reactions: fig

zgrav

Well-known member
update -- no problem with my terrarium pedals. swapped the daisy seeds and the older daisy seed works on both --- and the older seed works with the new build. Hope that information helps.
 
  • Like
Reactions: fig

zgrav

Well-known member
So the new Daisy Seeds are not working with the updated Terrarium Builds. But the updated Terrarium builds still work on the old Daisy Seeds. The LEDs work on the new Daisy Seed with the new Terrarium Builds, but no sound going through the pedal in bypass or when the effect is engaged.

Maybe something simple to fix.
 
  • Like
Reactions: fig

zgrav

Well-known member
Poked around a bit on the new Daisy Seed today using the Terrarium and discovered this for the updated Rhythmic Delay:

The audio IN is connected to a different channel that the audio OUT. The Daisy is getting sound going through it but coming out on pin 19 "Audio Out 2" You can short the two audio inputs on the Daisy together and get sound on the output jack (bridging the Audio 1 and Audio 2 inputs together) , or you can short the two output pins on the Daisy together and also get sound at the output jack.

I hope that is an easy fix for folks that are able to update the bin files for the Terrarium builds.
 
  • Like
Reactions: fig
@zgrav Thanks for taking the time to try out the new program and for tracking down the issue! I don't know why the audio input/output mapping for Seed v1.1 would have changed, but your right it did.

I just uploaded a new version of the Rhythmic Delay code (and compiled .bin) that works for both the Seed v1 and v1.1 with no Terrarium hardware alterations. The code can be found here, with the .bin in the 'build' directory. Let me know if you find any more issues, but I think this works now.
 

zgrav

Well-known member
@zgrav Thanks for taking the time to try out the new program and for tracking down the issue! I don't know why the audio input/output mapping for Seed v1.1 would have changed, but your right it did.

I just uploaded a new version of the Rhythmic Delay code (and compiled .bin) that works for both the Seed v1 and v1.1 with no Terrarium hardware alterations. The code can be found here, with the .bin in the 'build' directory. Let me know if you find any more issues, but I think this works now.
@sonic_explorer -- thanks again for taking the time to work on the build for the new Daisy Seeds. Sorry to report that the new build does not work at all with the new Daisy Seed. The LEDs do not blink after programming the Seed or when the Terrarium is powered. No sound comes through the in/out jacks. For comparison, flashing the prior build has the LEDs blinking normally. I did not check the new build to see if there is sound going through the input/output pins on the Daisy, but LMK if that would help and I will check.
 
  • Like
Reactions: fig
@zgrav I appreciate you trying things so quickly. Could you try to program the Seed v1.1 with the Rhythmic Delay again though? I got a pair of Seed v1.1 in the mail a few days ago and when I program them they seem to work fine with the .bin here. If it still doesn't work maybe something more tricky is going on.
 
  • Like
Reactions: fig

zgrav

Well-known member
@zgrav I appreciate you trying things so quickly. Could you try to program the Seed v1.1 with the Rhythmic Delay again though? I got a pair of Seed v1.1 in the mail a few days ago and when I program them they seem to work fine with the .bin here. If it still doesn't work maybe something more tricky is going on.
Will do. Thanks for the link. I loaded the bin file twice last night without success, and then reloaded the prior version to see if the LEDs still worked. I will try again this evening.
 
  • Like
Reactions: fig

zgrav

Well-known member
@zgrav I appreciate you trying things so quickly. Could you try to program the Seed v1.1 with the Rhythmic Delay again though? I got a pair of Seed v1.1 in the mail a few days ago and when I program them they seem to work fine with the .bin here. If it still doesn't work maybe something more tricky is going

@sonic_explorer The file you linked to is working great! Not sure what happened with the file when I d/l it last night but I did save it from the link without using the download button. It must make a difference.

Thanks for the follow-up!
 

fig

Village Idiot
Recompiled the files and added a three more binaries. Created a binaries directory. Need to solder on the pins to the new Daisies to test the binaries. Here's the URL if somebody is brave (dumb) enough to give it a whirl. Terranium binaries. [Note: it might take me a day or two - got a couple of analog pedals on workbench - been cranking them out the last 3-4 weeks (20+)]. This is just me messing around. I didn't release some of the source because I'm not sure what shape it's in. If anybody has any suggestions, I might be up to making some changes or adding the source code and letting you. I'm pretty good at porting the DaisyExamples code (when they make sense). If there's a project you want ported over, I can either do it or help you.
I've downloaded these and loaded the phaser flanger code. It sounds great! I'll give the others a spin (oops wrong platform) later this evening if I get time.

@sonic_explorer , I also loaded yours for a test drive. Very versatile delay sir!

Thank you both for coding and sharing these.
 
Last edited:

tcpoint

Well-known member
We should make a forum patch. I'd be happy to code it. The patches are fairly short (less than 1000 lines of code) so it shouldn't take too long. Then we could have a group test it and offer criticism. Everything like it needs more range, more treble, more bass, more delay time, etc. We could decide, up front, what to code, what the controls should be (we can always change some, later), etc. I'm not an dsp expert (I understand it to some degree) but I do program for a living. Just an idea.
 
Top