Pure Data / Pd

justin23000

Member
Ok next step.
We don't know where the command `hvcc` went. pd2dsy needs it.
Try

If that says nothing, then look next to the location of python, which you can find with

When you do find it, change the `--hvcc-cmd` option in the Makefile to point to the full path to it.
Tried this and got the location with
C++:
which hvcc
then took out the '--hvcc-cmd' and replaced it with
Code:
/c/Users/justi/AppData/Local/Programs/Python/Python310/Scripts/hvcc
Same results as before...

When I went back to look at the git repos, it looks like the makefile has just changed?

Is Python 3 okay to use then? The README says;

Test that you have python installed, and that its the proper version. It should be python 2, not python 3. Test this by running: `python --version`
Just checked this, it's Python 3.10.0. I can try to install a 2, it looks like there's a 2.7 available?
 

justin23000

Member
Thanks again for letting me baby-step through this with your help Fig and Shrimp.

Trying Python 2.7 and changing Python3 to Python in the Makefile gets me this, which I think we've seen before:
Code:
$ make
rm -r build patch.bin
rm: cannot remove 'build': No such file or directory
rm: cannot remove 'patch.bin': No such file or directory
make: [Makefile:4: patch.bin] Error 1 (ignored)
python pd2dsy/pd2dsy.py --hvcc_cmd hvcc --board petal --out_dir C:/Users/justi/terrarium-puredaisy/build patch.pd
['C:\\Users\\justi\\terrarium-puredaisy\\pd2dsy', 'C:\\WINDOWS\\SYSTEM32\\python27.zip', 'C:\\Python27\\DLLs', 'C:\\Python27\\lib', 'C:\\Python27\\lib\\plat-win', 'C:\\Python27\\lib\\lib-tk', 'C:\\Python27', 'C:\\Python27\\lib\\site-packages']
Converting patch for petal platform
Executing hvcc C:\Users\justi\terrarium-puredaisy\patch.pd  -o C:/Users/justi/terrarium-puredaisy/build -n patch -g c
Traceback (most recent call last):
  File "pd2dsy/pd2dsy.py", line 190, in <module>
  File "pd2dsy/pd2dsy.py", line 166, in main
AttributeError: 'module' object has no attribute 'run'
make: *** [Makefile:5: patch.bin] Error 1


Realized after a few minutes that I had not run make bootstrap after replacing Python, bootstrap got me this:
Code:
$ make bootstrap
git submodule init
git submodule update
cd pd2dsy && git submodule init
cd pd2dsy && git submodule update       
cd pd2dsy/hvcc && pip2.7 install .
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://p
ip.pypa.io/en/latest/development/release-process/#python-2-support
Processing c:\users\justi\terrarium-puredaisy\pd2dsy\hvcc
ERROR: Package 'hvcc' requires a different Python: 2.7.18 not in '>= 3.7'
WARNING: You are using pip version 19.2.3, however version 20.3.4 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
make: *** [Makefile:14: bootstrap] Error 1

The ominous part (mostly because it printed in red) looks like: ERROR: Package 'hvcc' requires a different Python: 2.7.18 not in '>= 3.7'
 
Top