Tommy and the vacuum cleaner

TSReppe

Active member
Kinda of a funny one, kind of a weird one.

I was just putting my Tommy III back in it’s enclosure last night after painting it. With the dpdt up it was all good and working like a charm. But with the dpdt downward there was this high pitched squeel that almost tore my ears of. I took it out of the enclosure again today to have a look and clean it properly. Put it back in and thought eureka, all great! no high pitch squeel. As I was fiddling around playing it my girlfriend decided to vacuum clean. All of a sudden I heard the squeel again and it got louder when she got closer and lower when she moved away again.
I thought I’d try replacing C9 and R12 since those are the only difference between the positions on the dpdt. But does anyone have a plausable explanation as to why this happens?
 

TSReppe

Active member
Edit:
Did some extra testing and I still get the squeal without the vacuum cleaner if I push the volume or gain knob all the way up. It’s late in my location so I‘ll let it rest for tonight. My guess now is it might be the opamp. Tests to do tomorrow!
 

cooder

Well-known member
What op amp are you using? I had squealing at certain settings with TL072, JRC4558 and others, disappeared with LM1458 opamp.
 
  • Like
Reactions: fig

TSReppe

Active member
What op amp are you using? I had squealing at certain settings with TL072, JRC4558 and others, disappeared with LM1458 opamp.
Did it disappear completely? I still have it, but I can push the knobs a little bit more. And to be honest the settings in which the squeal appear are pretty useless. Still gonna do some extra troubleshooting on this one.
 

TSReppe

Active member
Still hoping for some advice on this one. I noticed today that if I touch both the strings on the guitar and some metal on the pedal(pot or switch) the squeal disappears. Any idea where that means I should look?

I thought it might be something with C9, but I measure 5v so it should be fine. Changing opamp didn’t help at all I’m afraid. Extra annoying that I didn’t have this issue before I took it out of the enclosure to paint it. I used tape to make sure no paint got into the enclosure when spraying, but could there be something there?

Took a break while writing this to check if it’s the same with the dpdt in the other (low gain) position and there is. But I can of course push the knobs longer. There is a balance thing. If the bass pot is on full the other pots can go longer before it oscillates. Also if treble is on 0, gain and volume can go longer.
 

TSReppe

Active member
A little bit more testing showed that if I set the controls a little bit under the squeal-level I still get the squeals if I turn down the volume on my guitar a bit.
 

PJS

Active member
I wonder if you haven't got proper grounding to the enclosure. The jacks, pots, switches and footswitches all need to make proper ground with the enclosure. If it was not squealing at the start before you painted then I would guess that you have some paint on the inside of the enclosure stopping proper connections. Scrape away all the paint on the inside near the holes.
 

Chuck D. Bones

Well-known member
What op amp are you using? I had squealing at certain settings with TL072, JRC4558 and others, disappeared with LM1458 opamp.
It should not squeal with any of those opamps. Make sure the in & out wires are routed along the chassis walls away from the board. Like PJS said, check for proper grounding. If you are using a Tayda powder-coated enclosure, then you will need to scrape the paint inside.
 

TSReppe

Active member
It should not squeal with any of those opamps. Make sure the in & out wires are routed along the chassis walls away from the board. Like PJS said, check for proper grounding. If you are using a Tayda powder-coated enclosure, then you will need to scrape the paint inside.

I'll do some scraping and see what happens!

One thing I've forgot to mention is that it's built in a big chassis along a glory hole. The glory hole works just fine! But of course, there may be paint I havent noticed on Tommys side.
 
Top