Missing thermal reliefs on vias after import (Eagle to Kicad)


Well-known member
So.. I imported the board from Eagle to Kicad 7. In Eagle, the vias have thermal reliefs, but the thermal reliefs disappear after import. Any idea how to add them? There is nothing in the element properties.
Exactly. In Eagle there's a dedicated setting for the thermal isolation. I just can't find a similar feature in Kicad.

You can find the global setting in KiCAD here:
I've already been there.. there settings apply to the pads of the components and do not affect vias. At least in my projects.

What’s the benefit of using thermal reliefs on a via?

In double-sided DIY boards, I make vias "by hand", connecting the soldering pads with wire. Thermal reliefs make soldering much easier.
As promised, here's a workaround solution for you, @temol:
*images added as thumbnails, click to enlarge.

1. Head over to the Footprint Editor Utility.
2. Create a new Library.
1715346147827.png 1715346183786.png 1715346268529.png

3. Now we'll select the new library we named in the previous step and we're going to add a new footprint, name it, and select "Through Hole" as type.
1715346334784.png 1715346442620.png 1715346545359.png

4. Now, we'll add a pad to the footprint and customize the pad. In the last image, you can customize your thermal reliefs in the Thermal Relief Overrides section if you'd like.
1715346617699.png 1715346782881.png 1715346847844.png

Continued to next post due to image upload limit...
Continued from previous post...

5. Once you have your thermal settings entered for the pad on the new footprint, you'll need to set general settings. I like to hide all text from the footprint for something like this. Also be sure that you follow the settings in the bottom right of the window in my screenshot.

6. Save your settings and the new footprint. Head back to your board editor tool and insert the new footprint. Select the newly created footprint and add it to your board.
1715347308009.png 1715347359255.png 1715347390417.png

7. Once added, you can refill zones to see it's not connected to any nets. We'll need to change that. Make sure your selection filter has Pads selected and footprints unselected. Click on the new footprint and set the net to GND or whichever net you're using.
1715347504940.png 1715347550731.png 1715347648462.png

8. Now, when you refill your zones, you should see the thermals.

I realize this is not the most elegant solution, but it works. You can edit the thermal relief settings so yours are more reasonable than the ones shown in my last screenshot.

I hope this helps!
@Brett - thank you for the excellent solution and tutorial. I'll give it a try as soon as possible.
My current solution is not that elegant - I added a new set of spoked vias in Illustrator, before printing the transparencies.