A second failing Echo Foxtrot


Well-known member
Hi all,

Round two of a failing Echo Foxtrot built. My previous one would work for 30 seconds to a minute, and then sounds would fade out and stop altogether. If I pulled the power and waited a minute or two and tried again, it would start the process all over.

I just got another Echo Foxtrot board in today, and built it again. Same fade out issue exactly...

My guess is that the cheap Amazon L7806 voltage regulator I used on both. I had old docs on the first go round and it didn't mention it, so I had to scramble to get one in time to build it, instead of wait for another order from Tayda. I *think* they have a built-in shutoff mechanism if they get to hot.

My plan now is to get a new oneL7806, not from Amazon, and hope that that fixes the issue. I am still a bit concerned that it's happening at all though, since if it's happening because it is too hot, clearly there is some issue. If a different L7806 doesn't shutdown, is it because it has better heat tolerance?

Mostly posting this to vent lol. Here's hoping a new regulator will work, and if anyone has battled this issue as well, please chime in.
That's a weird one, firing up and functioning for 30 or so seconds before shutting off certainly points to the regulator, and you're correct that the L78** series do have a built-in thermal shutdown so they don't fry when they get too hot, but the EF86 heater should only be pulling about 200mA out of a device capable of supplying 1.5A, so with a 9V supply I wouldn't expect it to get that hot.

Swapping the regulator for one from a reputable seller (Tayda is reputable enough for parts like this, but with amazon you don't know what you're getting) would certainly be a logical next step.
As an update, I got a new L7806 from Mouser. I desoldered the old one on both boards and swapped in a new one, and they work... for slightly longer than they did before, and then they stop again 🤦‍♂️.

Really not sure what else to try at this point, I was sure this was going to be the fix. I compared with other builds on the forum and I have the ICs and MOSFET oriented properly, it does pass and amplify signal, it just won't stay on. Even bought a new board in case I just did something weird on the first one, no dice.

Any more ideas @vigilante398 , or anyone else? I guess I could swap out the IRF740? Got that one from Tayda per the build doc, so I'm assuming it's good. Same with the inductor. There's always the NE555 I guess too, socketed so it would be easy to swap. I just don't know how any of those would cause the symptoms I'm seeing.
I've tried 2 different EF-86s, I think I got them from Amplified parts, I forget, could have been ebay. I've tried both in each one, same results.

EDIT: I got them from Ebay, "NOS Svetlana WingedC EF86 6267"
Power supply. What are you using to power it? If you are using a multi line supply that is also feeding other pedals you may be exhausting the power. I ran into the exact same issue on my board with my recent build. On its own one spot independent from the board’s cs6 runs fine all day long. But when I power it with the cs6 even with its own dedicated output it powers up and a minute later fades slowly to nothing. I just have too much draw with all my other pedals to handle another tube pedal. So I have that one on its own one spot. Not sure if that’s what’s going on with yours but it sounds exactly like what I ran into. Good luck.

***One spot has 1700ma available. Your 500ma might not be enough? My generic 500ma supply’s won’t cut it for tube pedals.
Well that's weird. Winged C 6Ж32П are reliable, I've used them plenty, so no issue there. I agree that the symptoms don't really sound like a MOSFET, inductor, or NE555 problem.

500mA doesn't always cut it for tube pedals but where EF86 only pulls 200mA on the heater I would expect 500mA to be plenty. So here's where I would start:

I will preface this by saying that if you are not comfortable poking around an active high voltage circuit, please do not do it. No great tone is worth dying over. High voltage is present in this circuit even when the pedal is bypassed.

Measure voltages. A picture is worth a thousand words, but when troubleshooting a circuit, voltages are worth ten thousand words.
  1. Measure the input voltage. If you're using a 9V power supply but only seeing 5-6V on the input of the pedal, that's a clear sign that the pedal is trying to pull more juice than your power supply can put out.
  2. Measure the heater rail. If it reads 6V right when you plug it in then after a minute when your signal has faded reads 0V, that's a clear sign that your regulator is shutting off.
  3. Measure the high voltage rail. If your heater is still showing 6V even when the pedal has stopped passing signal, the issue may be in the high voltage section. It should read right around 230V (give or take a handful for component tolerances), so if it's significantly less than that then something may be straining the high voltage rail. The high voltage power supply is only capable of 30mA or so of output, so if there's a solder bridge or incorrect component that causes extra loading on it, it's not hard to make it sag.
I'll reemphasize that if you're not comfortable poking around inside the pedal please don't do it. If you can't figure anything out and don't have experience probing high voltage circuits shoot me a PM, I'd be willing to take a look at it for you.
Thanks @vigilante398 . I'm comfortable poking around at high voltages, so I will start measuring.

Can you tell me some good test point for the high voltage rail? I know where to find the 9V input voltage, and it looks like the heater voltage should be 6V on pin 5 of the tube/tube socket, but I'm not sure the best place to be looking for the 230V, as the schematic shows pins 6 and 8 at 200V.

@Dan0h Last time I had this issue I remember swapping out power supplies, but I just bought two more on Amazon, one more 500mA and one 1AM, just in case. I have been testing on a dedicated adapter thus far, but there's still a chance it could be the culprit. Thanks for the reminder.
OK, I have many tens thousands of words in updates! @vigilante398

Tried 2 power supplies, basically the same result. One is a Coda 1700mA straight to the wall DC PSU, and the other is an 18V to the wall that is being regulated to 9V by my fancy breaboard setup.

So input voltage. As soon as I plug it in, even with the effect bypassed, I start around 9V and start dropping slowly. The time matches about what I have been experiencing. Ultimately it drops to just about dead on 4.5V and stops, never rises, unless I disconnect everything and start over.

High voltage: I see 200+ initially, which also drops slowly, to around 130V, both on several of the tube socket pins, and what I think is some part of the SMPS (couldn't tell, I was using my test leads from the solder side). Either way, definitely getting way less than needed.

Heater voltage: I would see 6V on a couple of the tube socket pins, but eventually nothing (I think, lotta pins and it's early here...).

Hopefully this is enough to start doing some better troubleshooting. And idk why I never did this early on....
Last edited:
Okay, we're getting somewhere. You're not getting sound because the tube isn't getting power. If the circuit is pulling your power supply all the way down to 4.5V then you definitely have a problem in there. The main things I would look for are, in order:
  1. Solder bridges
  2. Bad/cold solder joints
  3. Anything shorting against the enclosure
  4. Incorrect component values
If none of those get you anywhere, try pulling the tube out and powering up the circuit and monitor the voltages like you did before but without the tube in place. If the voltages are still dropping, there's a problem in there somewhere that has nothing to do with the tube. If all the voltages stay up where they're supposed to be, it may very well be a tube issue.
Another update. I re-flowed each joint on each board to address 1 and 2 above, no change. I do not have either of them boxed up, so 3 is out. I think I already double checked my component values a while back, but I will do it again to be sure. I did swap both the BJT and the IC with no change.

It's so odd to me that both boards are having the identical issue. Makes me think there is a common component causing the problem. I did use the same batches of parts for each one for things like the power MOSFET.
Alright, pics galore. Let me know if any aren't clear enough or there's something you want more zoomed-in detail on.
Also I bought parts for a Particle Accelerator today from Mouser. There's some overlap on things like the diode and power MOSFET, so I bought some extras. Those 2 I have not swapped out yet, and may be worth trying with parts from a new batch.


  • signal-2023-02-15-133030_002.jpeg
    294.2 KB · Views: 14
  • signal-2023-02-15-133030_003.jpeg
    288 KB · Views: 12
  • signal-2023-02-15-133030_004.jpeg
    290.4 KB · Views: 11
  • signal-2023-02-15-133030_005.jpeg
    459.8 KB · Views: 12
  • signal-2023-02-15-133030_006.jpeg
    346.7 KB · Views: 13
  • signal-2023-02-15-133030_007.jpeg
    338.8 KB · Views: 15
  • signal-2023-02-15-133030_008.jpeg
    290.3 KB · Views: 13
  • signal-2023-02-15-133030_009.jpeg
    339.5 KB · Views: 12
  • signal-2023-02-15-133030_010.jpeg
    330.9 KB · Views: 12
  • signal-2023-02-15-133030_011.jpeg
    302.2 KB · Views: 13